Bulletin d'alerte Debian

DSA-1724-1 moodle -- Plusieurs vulnérabilités

Date du rapport :
13 février 2009
Paquets concernés :
moodle
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 514284.
Dans le dictionnaire CVE du Mitre : CVE-2009-0500, CVE-2009-0502, CVE-2008-5153.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans Moodle, un outil de gestion de cours en ligne. Le projet « Common Vulnerabilities and Exposures » (CVE) identifie les problèmes suivants.

  • CVE-2009-0500

    Il a été découvert que les informations stockées dans les tables de journalisation n'étaient pas correctement controlées. Ceci pourrait permettre à un attaquant d'injecter du code web arbitraire.

  • CVE-2009-0502

    Il a été découvert que certaines entrées de la fonction "Login as" n'étaient pas correctement controlées. Ceci permet d'injecter des scripts web arbitraires.

  • CVE-2008-5153

    Dmitry E. Oboukhov a découvert que le module SpellCheker crée des fichiers temporaires non sécurisés permettant une attaque par déni de service. Le module n'étant pas utilisé, il a été supprimé dans cette mise à jour.

Pour la distribution stable (Etch), ces problèmes ont été corrigés dans la version 1.6.3-2+etch2.

Pour la distribution testing (Lenny), ces problèmes ont été corrigés dans la version 1.8.2.dfsg-3+lenny1.

Pour la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 1.8.2.dfsg-4.

Nous vous recommandons de mettre à jour votre paquet moodle.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3-2+etch2.dsc
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3-2+etch2.diff.gz
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3-2+etch2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.