Säkerhetsbulletin från Debian

DSA-1724-1 moodle -- flera sårbarheter

Rapporterat den:
2009-02-13
Berörda paket:
moodle
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 514284.
I Mitres CVE-förteckning: CVE-2009-0500, CVE-2009-0502, CVE-2008-5153.
Ytterligare information:

Flera sårbarheter har upptäckts i Moodle, ett uppkopplat kurshanteringssystem. Projektet Common Vulnerabilities and Exposures identifierar följande problem:

  • CVE-2009-0500

    Det upptäcktes att den information som lagras i loggtabellerna inte städas korrekt, vilket kunde tillåta angripare att injicera godtycklig webbkod.

  • CVE-2009-0502

    Det upptäcktes att viss indata till Logga in som-funktionen inte städades tillräckligt, vilket ledde till injicering av godtyckliga webbskript.

  • CVE-2008-5153

    Dmitry E. Oboukhov upptäckte att insticksmodulen SpellCheker skapade tillfälliga filer på ett osäkert sätt, vilket tillät en överbelastningsattack. Eftersom insticksmodulen inte användes, har den tagits bort i denna uppdatering.

För den stabila utgåvan (Etch) har dessa problem rättats i version 1.6.3-2+etch2.

För uttestningsutgåvan (Lenny) har dessa problem rättats i version 1.8.2.dfsg-3+lenny1.

For the unstable (Sid) distribution har dessa problem rättats i version 1.8.2.dfsg-4.

Vi rekommenderar att ni uppgraderar ert moodle-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3-2+etch2.dsc
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3-2+etch2.diff.gz
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3.orig.tar.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/m/moodle/moodle_1.6.3-2+etch2_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.