Bulletin d'alerte Debian

DSA-1725-1 websvn -- Erreur de programmation

Date du rapport :
15 février 2009
Paquets concernés :
websvn
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 512191.
Dans le dictionnaire CVE du Mitre : CVE-2009-0240.
Plus de précisions :

Bas van Schaik a découvert que WebSVN, un outil pour visualiser les répertoires Subversion sur le web, ne restreint pas correctement l'accès aux dossiers privés, permettant à un attaquant distant de lire une part significative de leur contenu.

L'ancienne distribution stable (Sarge) n'est pas affectée par ce problème.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 2.0-4+lenny1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 2.0-4+lenny1.

Nous vous recommandons de mettre à jour votre paquet websvn.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/w/websvn/websvn_2.0-4+lenny1.diff.gz
http://security.debian.org/pool/updates/main/w/websvn/websvn_2.0-4+lenny1.dsc
http://security.debian.org/pool/updates/main/w/websvn/websvn_2.0.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/w/websvn/websvn_2.0-4+lenny1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.