Debian Security Advisory

DSA-1735-1 znc -- missing input sanitization

Date Reported:
10 Mar 2009
Affected Packages:
znc
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 516950.
In Mitre's CVE dictionary: CVE-2009-0759.
More information:

It was discovered that znc, an IRC proxy/bouncer, does not properly sanitize input contained in configuration change requests to the webadmin interface. This allows authenticated users to elevate their privileges and indirectly execute arbitrary commands (CVE-2009-0759).

For the old stable distribution (etch), this problem has been fixed in version 0.045-3+etch2.

For the stable distribution (lenny), this problem has been fixed in version 0.058-2+lenny1.

For the unstable distribution (sid), this problem has been fixed in version 0.066-1.

We recommend that you upgrade your znc packages.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Source:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045.orig.tar.gz
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2.dsc
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_amd64.deb
HP Precision:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/znc/znc_0.045-3+etch2_sparc.deb

Debian GNU/Linux 4.0 (lenny)

Source:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1.dsc
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1.diff.gz
http://security.debian.org/pool/updates/main/z/znc/znc_0.058.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/z/znc/znc_0.058-2+lenny1_sparc.deb

MD5 checksums of the listed files are available in the original advisory.