Debian セキュリティ勧告

DSA-1739-1 mldonkey -- パストラバーサル

報告日時:
2009-03-13
影響を受けるパッケージ:
mldonkey
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 516829.
Mitre の CVE 辞書: CVE-2009-0753.
詳細:

多種の P2P ネットワーク向けクライアント mldonkey に欠陥があり、細工され たリクエストを HTTP コンソールに送ることにより、攻撃者が任意のファイルを ダウンロード可能であることが発見されました。

旧安定版 (etch) にはこの問題の影響はありません。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョン 2.9.5-2+lenny1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題は近く修正 予定です。

直ぐに mldonkey パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey_2.9.5-2+lenny1.dsc
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey_2.9.5.orig.tar.gz
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey_2.9.5-2+lenny1.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_alpha.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_amd64.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_arm.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_armel.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_hppa.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_i386.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_ia64.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_mips.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_mipsel.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_powerpc.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_s390.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-server_2.9.5-2+lenny1_sparc.deb
http://security.debian.org/pool/updates/main/m/mldonkey/mldonkey-gui_2.9.5-2+lenny1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。