Debians sikkerhedsbulletin

DSA-1741-1 psi -- heltalsoverløb

Rapporteret den:
14. mar 2009
Berørte pakker:
psi
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 518468.
I Mitres CVE-ordbog: CVE-2008-6393.
Yderligere oplysninger:

Jesus Olmos Gonzalez opdagede et heltalsoverløb i PSI Jabber-klienten, der kunne føre til et fjernudført lammelsesangreb (denial of service).

Den gamle stabile distribution (etch) er ikke påvirket.

I den stabile distribution (lenny), er dette problem rettet i version 0.11-9.

I den ustabile distribution (sid), er dette problem rettet i version 0.12.1-1.

Vi anbefaler at du opgraderer din psi-pakke.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9.dsc
http://security.debian.org/pool/updates/main/p/psi/psi_0.11.orig.tar.gz
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_sparc.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.