Debian Security Advisory

DSA-1741-1 psi -- integer overflow

Date Reported:
14 Mar 2009
Affected Packages:
psi
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 518468.
In Mitre's CVE dictionary: CVE-2008-6393.
More information:

Jesus Olmos Gonzalez discovered that an integer overflow in the PSI Jabber client may lead to remote denial of service.

The old stable distribution (etch) is not affected.

For the stable distribution (lenny), this problem has been fixed in version 0.11-9.

For the unstable distribution (sid), this problem has been fixed in version 0.12.1-1.

We recommend that you upgrade your psi package.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Source:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9.dsc
http://security.debian.org/pool/updates/main/p/psi/psi_0.11.orig.tar.gz
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_sparc.deb

MD5 checksums of the listed files are available in the original advisory.