Säkerhetsbulletin från Debian

DSA-1741-1 psi -- heltalsspill

Rapporterat den:
2009-03-14
Berörda paket:
psi
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 518468.
I Mitres CVE-förteckning: CVE-2008-6393.
Ytterligare information:

Jesus Olmos Gonzalez upptäckte att ett heltalsspill i Jabberklienten PSI kan leda till överbelastning utifrån.

Den gamla stabila utgåvan (Etch) påverkas inte.

För den stabila utgåvan (Lenny) har detta problem rättats i version 0.11-9.

För den instabila utgåvan (Sid) har detta problem rättats i version 0.12.1-1.

Vi rekommenderar att ni uppgraderar ert psi-paket.

Rättat i:

Debian GNU/Linux 5.0 (lenny)

Källkod:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9.dsc
http://security.debian.org/pool/updates/main/p/psi/psi_0.11.orig.tar.gz
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/psi/psi_0.11-9_sparc.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.