Bulletin d'alerte Debian

DSA-1745-1 lcms -- Plusieurs vulnérabilités

Date du rapport :
20 mars 2009
Paquets concernés :
lcms
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2009-0581, CVE-2009-0723, CVE-2009-0733.
Plus de précisions :

Plusieurs problèmes de sécurité ont été découvertes dans LittleCMS, une bibliothèque de gestion de couleurs. Le projet « Common Vulnerabilities and Exposures » (CVE) identifie les problèmes suivants.

  • CVE-2009-0581

    Chris Evans a découvert que LittleCMS est concerné par une fuite de mémoire, qui pourrait conduire à un déni de service à l'aide de fichiers image contrefaits pour l'occasion.

  • CVE-2009-0723

    Chris Evans a découvert que LittleCMS est prédisposé à plusieurs dépassements d'entier à l'aide de fichiers image contrefaits pour l'occasion. Cela pourrait permettre l'exécution de code arbitraire.

  • CVE-2009-0733

    Chris Evans a découvert le manque de vérification de frontière haute des tailles menant à un dépassement de tampon, ce qui pourrait être utilisé pour exécuter du code arbitraire.

Pour la distribution stable (Lenny), ces problèmes ont été corrigés dans la version 1.17.dfsg-1+lenny1.

Pour la distribution oldstable (Etch), ces problèmes ont été corrigés dans la version 1.15-1.1+etch2.

Pour la distribution testing (Squeeze) et la distribution unstable (Sid), ces problèmes seront corrigés prochainement.

Nous vous recommandons de mettre à jour vos paquets lcms.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/l/lcms/lcms_1.15.orig.tar.gz
http://security.debian.org/pool/updates/main/l/lcms/lcms_1.15-1.1+etch2.diff.gz
http://security.debian.org/pool/updates/main/l/lcms/lcms_1.15-1.1+etch2.dsc
Alpha:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_alpha.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_alpha.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_amd64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_amd64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_arm.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_arm.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_arm.deb
HP Precision:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_hppa.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_hppa.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_i386.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_i386.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_ia64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_ia64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_mips.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_mips.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_mipsel.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_mipsel.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_powerpc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_s390.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_s390.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.15-1.1+etch2_sparc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.15-1.1+etch2_sparc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.15-1.1+etch2_sparc.deb

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/l/lcms/lcms_1.17.dfsg-1+lenny1.dsc
http://security.debian.org/pool/updates/main/l/lcms/lcms_1.17.dfsg-1+lenny1.diff.gz
http://security.debian.org/pool/updates/main/l/lcms/lcms_1.17.dfsg.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_alpha.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_alpha.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_alpha.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_amd64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_amd64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_amd64.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_arm.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_arm.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_arm.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_armel.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_armel.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_armel.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_hppa.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_hppa.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_hppa.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_i386.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_i386.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_i386.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_ia64.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_ia64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_ia64.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_mips.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_mips.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_mips.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_mipsel.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_mipsel.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_mipsel.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_powerpc.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_powerpc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_powerpc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_s390.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_s390.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_s390.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/l/lcms/liblcms1-dev_1.17.dfsg-1+lenny1_sparc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms1_1.17.dfsg-1+lenny1_sparc.deb
http://security.debian.org/pool/updates/main/l/lcms/python-liblcms_1.17.dfsg-1+lenny1_sparc.deb
http://security.debian.org/pool/updates/main/l/lcms/liblcms-utils_1.17.dfsg-1+lenny1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.