Debian Security Advisory

DSA-1753-1 iceweasel -- end-of-life announcement for Iceweasel in oldstable

Date Reported:
24 Mar 2009
Affected Packages:
Security database references:
No other external database security references currently available.
More information:

As indicated in the Etch release notes, security support for the Iceweasel version in the oldstable distribution (Etch) needed to be stopped before the end of the regular security maintenance life cycle.

You are strongly encouraged to upgrade to stable or switch to a still supported browser.

On a side note, please note that the Debian stable/Lenny version of Iceweasel - the unbranded version of the Firefox browser - links dynamically against the Xulrunner library. As such, most of the vulnerabilities found in Firefox need only be fixed in the Xulrunner package and don't require updates to the Iceweasel package any longer.