Debian セキュリティ勧告

DSA-1755-1 systemtap -- 競合

報告日時:
2009-03-25
影響を受けるパッケージ:
systemtap
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2009-0784.
詳細:

Erik Sjoelund さんにより、Linux 2.6 計測ツール Systemtap の stap ツールに 競合条件があり、stapusr グループのメンバの特権昇格を許すことが発見されま した。

旧安定版ディストリビューション (etch) には影響はありません。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョン 0.0.20080705-1+lenny1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョ ン 0.0.20090314-2 で修正されています。

直ぐに systemtap パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705.orig.tar.gz
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1.diff.gz
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1.dsc
AMD64:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1_ia64.deb
PowerPC:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/s/systemtap/systemtap_0.0.20080705-1+lenny1_s390.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。