Debian セキュリティ勧告

DSA-1773-1 cups -- 整数オーバフロー

報告日時:
2009-04-17
影響を受けるパッケージ:
cups
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2009-0163.
詳細:

共通 UNIX プリンティングシステム CUPS の imagetop フィルタが、細工された TIFF 画像を読む際に整数オーバフローを起こす欠陥が発見されました。

旧安定版 (oldstable) ディストリビューション (etch) では、この問題はバー ジョン 1.2.7-4etch7 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョン 1.3.8-1lenny5 で修正されています。

テスト版ディストリビューション (squeeze) および不安定版ディストリビューシ ョン (sid) では、この問題は近く修正予定です。

直ぐに cups パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7.dsc
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7.diff.gz
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-gnutls10_1.2.7-4etch7_all.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-common_1.2.7-4etch7_all.deb
Alpha:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_amd64.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_i386.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2-dev_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-dbg_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsimage2_1.2.7-4etch7_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.2.7-4etch7_sparc.deb

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5.dsc
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8.orig.tar.gz
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/c/cups/cupsys-dbg_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsys2-dev_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/cupsys-bsd_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/cupsys-common_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/cups-common_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsys2_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/cupsys_1.3.8-1lenny5_all.deb
http://security.debian.org/pool/updates/main/c/cups/cupsys-client_1.3.8-1lenny5_all.deb
Alpha:
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_alpha.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_amd64.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_arm.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_armel.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_hppa.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_i386.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_ia64.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_mips.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_s390.deb
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cups/cups-client_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/cups_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/cups-bsd_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2-dev_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/libcups2_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2-dev_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/cups-dbg_1.3.8-1lenny5_sparc.deb
http://security.debian.org/pool/updates/main/c/cups/libcupsimage2_1.3.8-1lenny5_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。