Säkerhetsbulletin från Debian

DSA-1774-1 ejabberd -- otillräcklig städning av indata

Rapporterat den:
2009-04-17
Berörda paket:
ejabberd
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2009-0934.
Ytterligare information:

Det upptäcktes att ejabberd, en distribuerad, feltolerant Jabber-/XMPP-server, inte städar MUC-loggar tillräckligt, vilket tillåter angripare utifrån att utföra serveröverskridande skriptangrepp (XSS-angrepp).

Den gamla stabila utgåvan (Etch) påverkas inte av detta problem.

För den stabila utgåvan (Lenny) har detta problem rättats i version 2.0.1-6+lenny1.

För uttestningsutgåvan (Squeeze) kommer detta problem att rättas inom kort.

För den instabila utgåvan (Sid) har detta problem rättats i version 2.0.5-1.

Vi rekommenderar att ni uppgraderar era ejabberd-paket.

Rättat i:

Debian GNU/Linux 5.0 (lenny)

Källkod:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1.diff.gz
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1.dsc
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_mips.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny1_sparc.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.