Bulletin d'alerte Debian

DSA-1778-1 mahara -- Vérification d'entrées manquante

Date du rapport :
22 avril 2009
Paquets concernés :
mahara
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2009-0664.
Plus de précisions :

Mahara, un portefeuille électronique complet, blog et créateur de curriculum vitæ, est prédisposé aux attaques de script intersite (XSS) à cause de l'absence de vérification des entrées du champ de texte de présentation dans les profils utilisateurs et de tous les champs de texte dans une vue utilisateur.

La distribution oldstable (Etch) ne contient pas mahara.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 1.0.4-4+lenny2.

Pour la distribution testing (Squeeze), ce problème sera corrigé prochainement.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 1.1.3-1.

Nous vous recommandons de mettre à jour vos paquets mahara.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4-4+lenny2.dsc
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4-4+lenny2.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4-4+lenny2_all.deb
http://security.debian.org/pool/updates/main/m/mahara/mahara-apache2_1.0.4-4+lenny2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.