Debian Security Advisory

DSA-1780-1 libdbd-pg-perl -- several vulnerabilities

Date Reported:
28 Apr 2009
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2009-0663, CVE-2009-1341.
More information:

Two vulnerabilities have been discovered in libdbd-pg-perl, the DBI driver module for PostgreSQL database access (DBD::Pg).

  • CVE-2009-0663

    A heap-based buffer overflow may allow attackers to execute arbitrary code through applications which read rows from the database using the pg_getline and getline functions. (More common retrieval methods, such as selectall_arrayref and fetchrow_array, are not affected.)

  • CVE-2009-1341

    A memory leak in the routine which unquotes BYTEA values returned from the database allows attackers to cause a denial of service.

For the old stable distribution (etch), these problems have been fixed in version 1.49-2+etch1.

For the stable distribution (lenny) and the unstable distribution (sid), these problems have been fixed in version 2.1.3-1 before the release of lenny.

We recommend that you upgrade your libdbd-pg-perl package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.