Bulletin d'alerte Debian

DSA-1791-1 moin -- Vérification d'entrées manquante

Date du rapport :
6 mai 2009
Paquets concernés :
moin
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 526594.
Dans le dictionnaire CVE du Mitre : CVE-2009-1482.
Plus de précisions :

L'action AttachFile dans Moin, un clone en Python de WikiWiki, est prédisposée aux attaques par script intersite lors du renommage des pièces jointes ou en réalisant d'autres sous-actions.

La distribution oldstable (Etch) n'est pas vulnérable.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 1.7.1-3+lenny2.

Pour les distributions testing (Squeeze) et unstable (Sid), ce problème sera bientôt corrigé.

Nous vous recommandons de mettre à jour vos paquets moin.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/m/moin/moin_1.7.1-3+lenny2.diff.gz
http://security.debian.org/pool/updates/main/m/moin/moin_1.7.1.orig.tar.gz
http://security.debian.org/pool/updates/main/m/moin/moin_1.7.1-3+lenny2.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/m/moin/python-moinmoin_1.7.1-3+lenny2_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.