Debian セキュリティ勧告

DSA-1799-1 qemu -- 複数の脆弱性

報告日時:
2009-05-11
影響を受けるパッケージ:
qemu
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2008-0928, CVE-2008-4539, CVE-2008-1945.
詳細:

QEMU プロセッサエミュレータに、複数の問題が発見されました。The Common Vulnerabilities and Exposures project は以下の問題を認識しています。

  • CVE-2008-0928

    Ian Jackson さんにより、エミュレートされたディスクデバイス処理での範 囲チェックが不十分にしか行われていないことが発見されました。

  • CVE-2008-1945

    リムーバブルメディアのフォーマット自動検出処理にバグがあり、ホストシ ステムのファイルの情報漏洩に繋がることが発見されました。

  • CVE-2008-4539

    Cirrus グラフィックアダプタのエミュレーションにバッファオーバフロー が発見されました。

旧安定版 (oldstable) ディストリビューション (etch) では、これらの問題は バージョン 0.8.2-4etch3 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、これらの問題はバ ージョン 0.9.1-10lenny1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、これらの問題はバー ジョン 0.9.1+svn20081101-1 で修正されています。

直ぐに qemu パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch3.diff.gz
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch3.dsc
AMD64:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch3_amd64.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.8.2-4etch3_i386.deb

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1.orig.tar.gz
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1-10lenny1.diff.gz
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1-10lenny1.dsc
AMD64:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1-10lenny1_amd64.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1-10lenny1_i386.deb
PowerPC:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1-10lenny1_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/q/qemu/qemu_0.9.1-10lenny1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。