Debian Security Advisory

DSA-1808-1 drupal6 -- insufficient input sanitising

Date Reported:
01 Jun 2009
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 529190, Bug 531386.
More information:

Markus Petrux discovered a cross-site scripting vulnerability in the taxonomy module of drupal6, a fully-featured content management framework. It is also possible that certain browsers using the UTF-7 encoding are vulnerable to a different cross-site scripting vulnerability.

For the stable distribution (lenny), these problems have been fixed in version 6.6-3lenny2.

The oldstable distribution (etch) does not contain drupal6.

For the testing distribution (squeeze) and the unstable distribution (sid), these problems have been fixed in version 6.11-1.1.

We recommend that you upgrade your drupal6 packages.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.