Debians sikkerhedsbulletin

DSA-1822-1 mahara -- utilstrækkelig fornuftighedskontrol af inddata

Rapporteret den:
23. jun 2009
Berørte pakker:
mahara
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
Der er pt. ingen tilgængelige eksterne sikkerhedsreferencer i andre databaser.
Yderligere oplysninger:

Man opdagede et mahara, et elektronisk portfolio-, weblog- og CV-program, var sårbart over for flere angreb i forbindelse med udførelse af skripter på tværs af websteder, hvilket gjorde det muligt for en angriber, at indsprøjte vilkårlig HTML- eller skriptkode samt stjæle potentielt følsomme data fra andre brugere.

Den gamle stabile distribution (etch) indeholder ikke mahara.

I den stabile distribution (lenny), er dette problem rettet i version 1.0.4-4+lenny3.

I distributionen testing (squeeze), vil dette problem snart blive rettet.

I den ustabile distribution (sid), er dette problem rettet i version 1.1.5-1.

Vi anbefaler at du opgraderer dine mahara-pakker.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4-4+lenny3.diff.gz
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4-4+lenny3.dsc
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/m/mahara/mahara_1.0.4-4+lenny3_all.deb
http://security.debian.org/pool/updates/main/m/mahara/mahara-apache2_1.0.4-4+lenny3_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.