Debians sikkerhedsbulletin

DSA-1829-1 sork-passwd-h3 -- utilstrækkelig fornuftighedskontrol af inddata

Rapporteret den:
11. jul 2009
Berørte pakker:
sork-passwd-h3
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 536554.
I Mitres CVE-ordbog: CVE-2009-2360.
Yderligere oplysninger:

Man opdagede at sork-passwd-h3, et Horde3-modul der gør at brugerne kan ændre deres adgangskoder, var sårbar over et angreb i forbindelse med udførelse af skripter på tværs af websteder gennem backend-parameteret.

I den gamle stabile distribution (etch), er dette problem rettet i version 3.0-2+etch1.

I den stabile distribution (lenny), er dette problem rettet i version 3.0-2+lenny1.

I distributionen testing (squeeze), vil dette problem snart blive rettet.

I den ustabile distribution (sid), er dette problem rettet i version 3.1-1.1.

Vi anbefaler at du opgraderer dine sork-passwd-h3-pakker.

Rettet i:

Debian GNU/Linux 4.0 (etch)

Kildekode:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1.dsc
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1.diff.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1.dsc
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1.diff.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.