Debian セキュリティ勧告

DSA-1829-1 sork-passwd-h3 -- 入力のサニタイズ不足

報告日時:
2009-07-11
影響を受けるパッケージ:
sork-passwd-h3
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 536554.
Mitre の CVE 辞書: CVE-2009-2360.
詳細:

ユーザがパスワードを変更するための Horde3 モジュール sork-passwd-h3 に、 backend パラメータを使ったクロスサイトスクリプティング攻撃を許す欠陥が 発見されました。

旧安定版 (oldstable) ディストリビューション (etch) では、この問題はバー ジョン 3.0-2+etch1 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 3.0-2+lenny1 で修正されています。

テスト版ディストリビューション (squeeze) では、この問題は近く修正予定で す。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージ ョン 3.1-1.1 で修正されています。

直ぐに sork-passwd-h3 パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1.dsc
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1.dsc
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。