Säkerhetsbulletin från Debian

DSA-1829-1 sork-passwd-h3 -- otillräcklig städning av indata

Rapporterat den:
2009-07-11
Berörda paket:
sork-passwd-h3
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 536554.
I Mitres CVE-förteckning: CVE-2009-2360.
Ytterligare information:

Det upptäcktes att sork-passwd-h3, en Horde3-modul där användare kan ändra sina lösenord, är sårbar för ett serveröverskridande skriptproblem via backend-parametern.

För den gamla stabila utgåvan (Etch) har detta problem rättats i version 3.0-2+etch1.

För den stabila utgåvan (Lenny) har detta problem rättats i version 3.0-2+lenny1.

För uttestningsutgåvan (Squeeze) kommer detta problem att rättas inom kort.

För den instabila utgåvan (Sid) har detta problem rättats i version 3.1-1.1.

Vi rekommenderar att ni uppgraderar era sork-passwd-h3-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1.dsc
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

Källkod:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1.dsc
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0.orig.tar.gz
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/s/sork-passwd-h3/sork-passwd-h3_3.0-2+lenny1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.