Debian セキュリティ勧告

DSA-1831-1 djbdns -- プログラムミス

報告日時:
2009-07-13
影響を受けるパッケージ:
djbdns
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 518169.
Mitre の CVE 辞書: CVE-2009-0858.
詳細:

Matthew Dempsky さんにより、Daniel J. Bernstein 氏によるドメインネー ムサーバの djbdns がオフセットを要求仕様通り制限していないため、 tinydns や axfrdns でサービスされているサードパーティのサブドメインの 制御権を持つリモートの攻撃者から、このサブドメインの細工されたゾーン データを用いて任意のレコードを含む DNS レスポンスを送ることができるこ とが発見されました。

旧安定版 (etch) には djbdns パッケージは収録されていません。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージ ョン 1.05-4+lenny1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 1.05-5 で修正されています。

直ぐに djbdns パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05.orig.tar.gz
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1.dsc
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/d/djbdns/dnscache-run_1.05-4+lenny1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_alpha.deb
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_amd64.deb
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_arm.deb
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_armel.deb
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_hppa.deb
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_i386.deb
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_ia64.deb
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_mips.deb
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_mipsel.deb
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_powerpc.deb
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_s390.deb
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/d/djbdns/dbndns_1.05-4+lenny1_sparc.deb
http://security.debian.org/pool/updates/main/d/djbdns/djbdns_1.05-4+lenny1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。