Debian Security Advisory

DSA-1846-1 kvm -- denial of service

Date Reported:
28 Jul 2009
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2009-2287.
More information:

Matt T. Yourst discovered an issue in the kvm subsystem. Local users with permission to manipulate /dev/kvm can cause a denial of service (hang) by providing an invalid cr3 value to the KVM_SET_SREGS call.

For the stable distribution (lenny), these problems have been fixed in version 72+dfsg-5~lenny2.

For the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your kvm packages, and rebuild any kernel modules you have built from a kvm-source package version.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:
Intel IA-32:

MD5 checksums of the listed files are available in the original advisory.