Debians sikkerhedsbulletin

DSA-1856-1 mantis -- informationslækage

Rapporteret den:
8. aug 2009
Berørte pakker:
mantis
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 425010.
Yderligere oplysninger:

Man opdagede at pakken Debian Mantis, et webbaseret fejlsporingssystem, installerede databaseadgangsoplysningerne i en fil med verdensskrivbare rettigheder på det lokale filsystem. Det gjorde det muligt for lokale brugere at få adgang til oplysningerne, der anvendes til at kontrollere Mantis-databasen.

Denne opdaterede pakke retter problemet ved nyinstalleringer og vil omhyggeligt forsøge at updatere eksisterende installationer. Administratorer kan kontrollere rettighederne hørende til filen /etc/mantis/config_db.php for at se om de er sikre i deres miljø.

Den gamle stabile distribution (etch) indeholder ikke pakken mantis.

I den stabile distribution (lenny), er dette problem rettet i version 1.1.6+dfsg-2lenny1.

I den ustabile distribution (sid), er dette problem rettet i version 1.1.8+dfsg-2.

Vi anbefaler at du opgraderer din mantis-pakke.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/m/mantis/mantis_1.1.6+dfsg.orig.tar.gz
http://security.debian.org/pool/updates/main/m/mantis/mantis_1.1.6+dfsg-2lenny1.dsc
http://security.debian.org/pool/updates/main/m/mantis/mantis_1.1.6+dfsg-2lenny1.diff.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/m/mantis/mantis_1.1.6+dfsg-2lenny1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.