Debian Security Advisory

DSA-1887-1 rails -- missing input sanitising

Date Reported:
15 Sep 2009
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 545063.
In Mitre's CVE dictionary: CVE-2009-3009.
More information:

Brian Mastenbrook discovered that rails, the MVC ruby based framework geared for web application development, is prone to cross-site scripting attacks via malformed strings in the form helper.

For the oldstable distribution (etch) security support has been discontinued. It has been reported that rails in oldstable is unusable and several features that are affected by security issues are broken due to programming issues. It is highly recommended to upgrade to the version in stable (lenny).

For the stable distribution (lenny), this problem has been fixed in version 2.1.0-7.

For the testing distribution (squeeze) and the unstable distribution (sid), this problem has been fixed in version 2.2.3-1.

We recommend that you upgrade your rails packages.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.