Debian セキュリティ勧告

DSA-1897-1 horde3 -- 入力の不十分なサニタイズ

報告日時:
2009-09-28
影響を受けるパッケージ:
horde3
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2009-3236.
詳細:

Stefan Esser さんにより、プリファレンス・圧縮。ブラウザ検出を扱うクラス を提供する Web アプリケーションフレームワーク Horde がユーザの提供する 入力を適切に検証及びエスケープしていないことが発見されました。 Horde_Form_Type_image フォーム要素が、事前の検証なしに Hidden HTML フィ ールド中に格納された一時ファイル名を、再アップロードの際に再利用するこ とを許しています。攻撃者はこの欠陥を悪用してシステムの任意のファイルを 上書き可能、または任意の PHP コードをアップロードし、ウェブサーバ権限で 実行可能です。

旧安定版 (oldstable) ディストリビューション (etch) では、この問題はバー ジョン 3.1.3-4etch6 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 3.2.2+debian0-2+lenny1 で修正されています。

テスト版ディストリビューション (squeeze) では、この問題はバージョン 3.3.5+debian0-1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージ ョン 3.3.5+debian0-1 で修正されています。

直ぐに horde3 パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3-4etch6.diff.gz
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3-4etch6.dsc
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3.orig.tar.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.1.3-4etch6_all.deb

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.2.2+debian0-2+lenny1.dsc
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.2.2+debian0.orig.tar.gz
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.2.2+debian0-2+lenny1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/h/horde3/horde3_3.2.2+debian0-2+lenny1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。