Debians sikkerhedsbulletin

DSA-1913-1 bugzilla -- SQL-indspøjtningssårbarhed

Rapporteret den:
17. okt 2009
Berørte pakker:
bugzilla
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 547132.
I Mitres CVE-ordbog: CVE-2009-3165.
Yderligere oplysninger:

Max Kanat-Alexander, Bradley Baetz og Frédéric Buclin opdagede en SQL-indspøjtningssårbarhed i funktionen Bug.create WebService i Bugzilla, et webbaseret fejlsporingssystem, hvilket gjorde det muligt for fjernangribere at udføre vilkårlige SQL-kommandoer.

Den gamle stabile distribution (etch) er ikke påvirket af dette problem.

I den stabile distribution (lenny), er dette problem rettet i version 3.0.4.1-2+lenny2.

I distributionen testing (squeeze) og i den ustabile distribution (sid), vil dette problem snart blive rettet.

Vi anbefaler at du opgraderer dine bugzilla-pakker.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla_3.0.4.1-2+lenny2.dsc
http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla_3.0.4.1-2+lenny2.diff.gz
http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla_3.0.4.1.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla3_3.0.4.1-2+lenny2_all.deb
http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla3-doc_3.0.4.1-2+lenny2_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.