Debian Security Advisory

DSA-1919-1 smarty -- several vulnerabilities

Date Reported:
25 Oct 2009
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 504328, Bug 529810.
In Mitre's CVE dictionary: CVE-2008-4810, CVE-2009-1669.
More information:

Several remote vulnerabilities have been discovered in Smarty, a PHP templating engine. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2008-4810

    The _expand_quoted_text function allows for certain restrictions in templates, like function calling and PHP execution, to be bypassed.

  • CVE-2009-1669

    The smarty_function_math function allows context-dependent attackers to execute arbitrary commands via shell metacharacters in the equation attribute of the math function.

For the old stable distribution (etch), these problems have been fixed in version 2.6.14-1etch2.

For the stable distribution (lenny), these problems have been fixed in version 2.6.20-1.2.

For the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your smarty package.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.