Bulletin d'alerte Debian

DSA-1938-1 php-mail -- Erreur de programmation

Date du rapport :
23 novembre 2009
Paquets concernés :
php-mail
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Aucune référence à une base de données externe en rapport avec la sécurité n'est actuellement disponible.
Plus de précisions :

Mail, un module PEAR PHP pour envoyer des courriers électroniques, a une vérification d'entrées manquante, ce qui pourrait être utilisé pour obtenir des données sensibles sur le système qui l'utilise.

Pour la distribution oldstable (Etch), ce problème a été corrigé dans la version 1.1.6-2+etch1.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 1.1.14-1+lenny1.

Pour la distribution testing (Squeeze), ce problème sera corrigé prochainement.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 1.1.14-2.

Nous vous recommandons de mettre à jour vos paquets php-mail.

Corrigé dans :

Debian GNU/Linux 4.0 (etch)

Source :
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6.orig.tar.gz
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1.diff.gz
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1.dsc
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14.orig.tar.gz
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.