Säkerhetsbulletin från Debian

DSA-1938-1 php-mail -- programmeringsfel

Rapporterat den:
2009-11-23
Berörda paket:
php-mail
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
För närvarande är inga ytterligare referenser till externa säkerhetsdatabaser tillgängliga.
Ytterligare information:

Det upptäcktes att php-mail, en PHP PEAR-modul för sändning av e-post, inte städar indata tillräckligt, vilket kan användas för att erhålla känslig datat från det system som använder php-mail.

För den gamla stabila utgåvan (Etch) har detta problem rättats i version 1.1.6-2+etch1.

För den stabila utgåvan (Lenny) har detta problem rättats i version 1.1.14-1+lenny1.

För uttestningsutgåvan (Squeeze) kommer detta problem att rättas inom kort.

För den instabila utgåvan (Sid) har detta problem rättats i version 1.1.14-2.

Vi rekommenderar att ni uppgraderar era php-mail-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6.orig.tar.gz
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1.diff.gz
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1.dsc
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.6-2+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

Källkod:
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1.dsc
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14.orig.tar.gz
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/php-mail/php-mail_1.1.14-1+lenny1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.