Säkerhetsbulletin från Debian

DSA-1949-1 php-net-ping -- programmeringsfel

Rapporterat den:
2009-12-12
Berörda paket:
php-net-ping
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Mitres CVE-förteckning: CVE-2009-4024.
Ytterligare information:

Det upptäcktes att php-net-ping, en PHP PEAR-modul för exekvering av ping oberoende av operativsystemet, inte städar indata tillräckligt, vilket kan användas för att injicera argument (ingen CVE ännu) eller exekvera godtyckliga kommandon (CVE-2009-4024) på ett system som använder php-net-ping.

För den gamla stabila utgåvan (Etch) har detta problem rättats i version 2.4.2-1+etch1.

För den stabila utgåvan (Lenny) har detta problem rättats i version 2.4.2-1+lenny1.

För uttestningsutgåvan (Squeeze) kommer detta problem att rättas inom kort.

För den instabila utgåvan (Sid) har detta problem rättats i version 2.4.2-1.1.

Vi rekommenderar att ni uppgraderar era php-net-ping-paket.

Rättat i:

Debian GNU/Linux 4.0 (etch)

Källkod:
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2-1+etch1.diff.gz
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2.orig.tar.gz
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2-1+etch1.dsc
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2-1+etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

Källkod:
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2.orig.tar.gz
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2-1+lenny1.dsc
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2-1+lenny1.diff.gz
Arkitekturoberoende komponent:
http://security.debian.org/pool/updates/main/p/php-net-ping/php-net-ping_2.4.2-1+lenny1_all.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.