Debian セキュリティ勧告

DSA-1951-1 firefox-sage -- 入力のサニタイズ不足

報告日時:
2009-12-15
影響を受けるパッケージ:
firefox-sage
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 559267.
Mitre の CVE 辞書: CVE-2009-4102.
詳細:

Firefox 向け軽量 RSS および Atom フィードリーダ firefox-sage が RSS フ ィード情報を適切にサニタイズしていないため、クロスサイトスクリプティン グ攻撃やクロスドメインスクリプティング攻撃にたいして脆弱であることが発 見されました。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 1.4.2-0.1+lenny1 で修正されています。

旧安定版 (oldstable) ディストリビューション (etch) では、この問題はバー ジョン 1.3.6-4etch1 で修正されています。

テスト版 (squeeze) および不安定版 (unstable) ディストリビューション では、この問題はバージョン 1.4.3-3 で修正されています。

直ぐに firefox-sage パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 4.0 (etch)

ソース:
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.3.6-4etch1.dsc
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.3.6.orig.tar.gz
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.3.6-4etch1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.3.6-4etch1_all.deb

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.4.2-0.1+lenny1.diff.gz
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.4.2.orig.tar.gz
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.4.2-0.1+lenny1.dsc
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/f/firefox-sage/firefox-sage_1.4.2-0.1+lenny1_all.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。