Debian Security Advisory

DSA-1954-1 cacti -- insufficient input sanitising

Date Reported:
16 Dec 2009
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 429224.
In Mitre's CVE dictionary: CVE-2007-3112, CVE-2007-3113, CVE-2009-4032.
More information:

Several vulnerabilities have been found in cacti, a frontend to rrdtool for monitoring systems and services. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2007-3112, CVE-2007-3113

    It was discovered that cacti is prone to a denial of service via the graph_height, graph_width, graph_start and graph_end parameters. This issue only affects the oldstable (etch) version of cacti.

  • CVE-2009-4032

    It was discovered that cacti is prone to several cross-site scripting attacks via different vectors.

  • CVE-2009-4112

    It has been discovered that cacti allows authenticated administrator users to gain access to the host system by executing arbitrary commands via the "Data Input Method" for the "Linux - Get Memory Usage" setting.

    There is no fix for this issue at this stage. Upstream will implement a whitelist policy to only allow certain "safe" commands. For the moment, we recommend that such access is only given to trusted users and that the options "Data Input" and "User Administration" are otherwise deactivated.

For the oldstable distribution (etch), these problems have been fixed in version 0.8.6i-3.6.

For the stable distribution (lenny), this problem has been fixed in version 0.8.7b-2.1+lenny1.

For the testing distribution (squeeze), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in version 0.8.7e-1.1.

We recommend that you upgrade your cacti packages.

Fixed in:

Debian GNU/Linux 4.0 (etch)

Architecture-independent component:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.