Debian Security Advisory

DSA-1990-1 trac-git -- shell command injection

Date Reported:
03 Feb 2010
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 567039.
In Mitre's CVE dictionary: CVE-2010-0394.
More information:

Stefan Goebel discovered that the Debian version of trac-git, the Git add-on for the Trac issue tracking system, contains a flaw which enables attackers to execute code on the web server running trac-git by sending crafted HTTP queries.

The old stable distribution (etch) does not contain a trac-git package.

For the stable distribution (lenny), this problem has been fixed in version 0.0.20080710-3+lenny1.

For the unstable distribution (sid) and the testing distribution (squeeze), this problem has been fixed in version 0.0.20090320-1.

We recommend that you upgrade your trac-git package.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.