Debians sikkerhedsbulletin

DSA-1990-1 trac-git -- shell-kommandoindsprøjtning

Rapporteret den:
3. feb 2010
Berørte pakker:
trac-git
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 567039.
I Mitres CVE-ordbog: CVE-2010-0394.
Yderligere oplysninger:

Stefan Goebel opdagede at Debians version af trac-git, Git-udvidelsen til fejlsporingssystemet Trac, indeholdt en fejl, som gjorde det muligt for angribere at udføre kode på webserveren, der kører trac-git, ved at sende fabrikerede HTTP-forespørgsler.

Den gamle stabile distribution (etch) indeholder ikke en trac-git-pakke.

I den stabile distribution (lenny), er dette problem rettet i version 0.0.20080710-3+lenny1.

I den ustabile distribution (sid) og i distributionen testing (squeeze), er dette problem rettet i version 0.0.20090320-1.

Vi anbefaler at du opgraderer din trac-git-pakke.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/t/trac-git/trac-git_0.0.20080710-3+lenny1.dsc
http://security.debian.org/pool/updates/main/t/trac-git/trac-git_0.0.20080710-3+lenny1.diff.gz
http://security.debian.org/pool/updates/main/t/trac-git/trac-git_0.0.20080710.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/t/trac-git/trac-git_0.0.20080710-3+lenny1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.