Debian Security Advisory

DSA-1993-1 otrs2 -- sql injection

Date Reported:
10 Feb 2010
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2010-0438.
More information:

It was discovered that otrs2, the Open Ticket Request System, does not properly sanitise input data that is used on SQL queries, which might be used to inject arbitrary SQL to, for example, escalate privileges on a system that uses otrs2.

The oldstable distribution (etch) is not affected.

For the stable distribution (lenny), the problem has been fixed in version 2.2.7-2lenny3.

For the testing distribution (squeeze), the problem will be fixed soon.

For the unstable distribution (sid), the problem has been fixed in version 2.4.7-1.

We recommend that you upgrade your otrs2 packages.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.