Debians sikkerhedsbulletin

DSA-2009-1 tdiary -- utilstrækkelig fornuftighedskontrol af inddata

Rapporteret den:
9. mar 2010
Berørte pakker:
tdiary
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 572417.
I Mitres CVE-ordbog: CVE-2010-0726.
Yderligere oplysninger:

Man opdagede at tdiary, et kommunikationsvenligt weblogsystem, var sårbart over for en sårbarhed i forbindelse med udførelse af skripter på tværs af websteder, på grund af utilstrækkelig fornuftighedskontrol af inddata i transmission-plugin'en TrackBack.

I den stabile distribution (lenny), er dette problem rettet i version 2.2.1-1+lenny1.

I distributionen testing (squeeze), vil dette problem snart blive rettet.

I den ustabile distribution (sid), er dette problem rettet i version 2.2.1-1.1.

Vi anbefaler at du opgraderer dine tdiary-pakker.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1-1+lenny1.dsc
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1-1+lenny1.diff.gz
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1.orig.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-theme_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-contrib_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-plugin_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-mode_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1-1+lenny1_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.