Рекомендация Debian по безопасности

DSA-2009-1 tdiary -- недостаточная очистка ввода

Дата сообщения:
09.03.2010
Затронутые пакеты:
tdiary
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 572417.
В каталоге Mitre CVE: CVE-2010-0726.
Более подробная информация:

Было обнаружено, что tdiary, система ведения блога с поддержкой различных способов взаимодействия, уязвима к межсайтовому скриптингу в связи с недостаточной очисткой ввода в дополнении TrackBack для transmission.

В стабильном выпуске (lenny) эта проблема была исправлена в версии 2.2.1-1+lenny1.

В тестируемом выпуске (squeeze) эта проблема будет исправлена позже.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 2.2.1-1.1.

Рекомендуется обновить пакеты tdiary.

Исправлено в:

Debian GNU/Linux 5.0 (lenny)

Исходный код:
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1-1+lenny1.dsc
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1-1+lenny1.diff.gz
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1.orig.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-theme_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-contrib_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-plugin_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary-mode_2.2.1-1+lenny1_all.deb
http://security.debian.org/pool/updates/main/t/tdiary/tdiary_2.2.1-1+lenny1_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.