Debians sikkerhedsbulletin

DSA-2020-1 ikiwiki -- utilstrækkelig fornuftighedskontrol af inddata

Rapporteret den:
20. mar 2010
Berørte pakker:
ikiwiki
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
Der er pt. ingen tilgængelige eksterne sikkerhedsreferencer i andre databaser.
Yderligere oplysninger:

Ivan Shmakov opdagede at htmlscrubber-komponenten i ikiwiki, en wikicompiler, udførte utilstrækkelig fornuftighedskontrol af inddata på data:image/svg+xml-URI'er. Da de kan indeholde skriptkode, kunne det anvendes af en angriber til at udføre skripter på tværs af websteder.

I den stabile distribution (lenny), er dette problem rettet i version 2.53.5.

I distributionen testing (squeeze), er dette problem rettet i version 3.20100312.

I den ustabile distribution (sid), er dette problem rettet i version 3.20100312.

Rettet i:

Debian GNU/Linux 5.0 (lenny)

Kildekode:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_2.53.5.dsc
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_2.53.5.tar.gz
Arkitekturuafhængig komponent:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_2.53.5_all.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.