Рекомендация Debian по безопасности

DSA-2020-1 ikiwiki -- недостаточная очистка ввода

Дата сообщения:
20.03.2010
Затронутые пакеты:
ikiwiki
Уязвим:
Да
Ссылки на базы данных по безопасности:
На данный момент ссылки на внешние базы данных по безопасности отсутствуют.
Более подробная информация:

Иван Шмаков обнаружил, что компонент htmlscrubber для ikiwiki, вики-компилятора, выполняет недостаточную очистку ввода в URI вида data:image/svg+xml. Поскольку они могут содержить код сценариев, эта уязвимость может использоваться злоумышленниками для выполнения межсайтового скриптинга.

В стабильном выпуске (lenny) эта проблема была исправлена в версии 2.53.5.

В тестируемом выпуске (squeeze) эта проблема была исправлена в версии 3.20100312.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 3.20100312.

Исправлено в:

Debian GNU/Linux 5.0 (lenny)

Исходный код:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_2.53.5.dsc
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_2.53.5.tar.gz
Независимые от архитектуры компоненты:
http://security.debian.org/pool/updates/main/i/ikiwiki/ikiwiki_2.53.5_all.deb

Контрольные суммы MD5 этих файлов доступны в исходном сообщении.