Bulletin d'alerte Debian

DSA-2028-1 xpdf -- Plusieurs vulnérabilités

Date du rapport :
5 avril 2010
Paquets concernés :
xpdf
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 551287.
Dans le dictionnaire CVE du Mitre : CVE-2009-1188, CVE-2009-3603, CVE-2009-3604, CVE-2009-3606, CVE-2009-3608, CVE-2009-3609.
Plus de précisions :

Plusieurs vulnérabilités ont été identifiée dans xpdf, un ensemble d'outils pour afficher et convertir des fichiers Portable Document Format (PDF).

Le projet « Common Vulnerabilities and Exposures » (CVE) identifie les problèmes suivants.

  • CVE-2009-1188 et CVE-2009-3603

    Un débordement d'entier dans SplashBitmap::SplashBitmap pourrait permettre à des attaquants distants d'exécuter du code arbitraire ou de provoquer un plantage d'application à l'aide d'un document PDF contrefait.

  • CVE-2009-3604

    Un déréférencement de pointeur NULL ou un débordement de mémoire tampon basée sur le tas dans Splash::drawImage pourrait permettre à des attaquants distants de provoquer un déni de service (plantage d'application) ou éventuellement d'exécuter du code arbitraire à l'aide d'un document PDF contrefait.

  • CVE-2009-3606

    Un débordement d'entier dans PSOutputDev::doImageL1Sep pourrait permettre à des attaquants distants d'exécuter du code arbitraire à l'aide d'un document PDF contrefait.

  • CVE-2009-3608

    Un débordement d'entier dans ObjectStream::ObjectStream pourrait permettre à des attaquants distants d'exécuter du code arbitraire à l'aide d'un document PDF contrefait.

  • CVE-2009-3609

    Un débordement d'entier dans ImageStream::ImageStream pourrait permettre à des attaquants distants de provoquer un déni de service à l'aide d'un document PDF contrefait.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 3.02-1.4+lenny2.

Pour la distribution testing (Squeeze), ce problème sera corrigé prochainement.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 3.02-2.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02.orig.tar.gz
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02-1.4+lenny2.diff.gz
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02-1.4+lenny2.dsc
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02-1.4+lenny2_all.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-common_3.02-1.4+lenny2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_alpha.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_amd64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_arm.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_armel.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_hppa.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_i386.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_ia64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_ia64.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_powerpc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_s390.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_sparc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.