Debian セキュリティ勧告

DSA-2028-1 xpdf -- 複数の脆弱性

報告日時:
2010-04-05
影響を受けるパッケージ:
xpdf
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 551287.
Mitre の CVE 辞書: CVE-2009-1188, CVE-2009-3603, CVE-2009-3604, CVE-2009-3606, CVE-2009-3608, CVE-2009-3609.
詳細:

複数の欠陥が、Portable Document Format (PDF) ファイルを表示・変更するた めのツール群 xpdf に発見されました。

The Common Vulnerabilities and Exposures project は以下の問題を認識して います。

  • CVE-2009-1188 and CVE-2009-3603

    SplashBitmap::SplashBitmap に整数オーバフローがあり、リモートの攻撃 者が細工した PDF ファイルを用いて任意のコードの実行や、アプリケーシ ョンのクラッシュを実行可能です。

  • CVE-2009-3604

    NULL pointer dereference or heap-based buffer overflow in Splash::drawImage に NULL ポインタ参照とヒープベースのバッファオー バフローがあり、リモートの攻撃者が細工した PDF ファイルを用いて任意 のコードの実行や、サービス拒否攻撃 (アプリケーションのクラッシュ) を実行可能です。

  • CVE-2009-3606

    Integer overflow in the PSOutputDev::doImageL1Sep に整数オーバフロ ーがあり、リモートの攻撃者が細工した PDF ファイルを用いて任意のコー ドを実行可能です。

  • CVE-2009-3608

    Integer overflow in the ObjectStream::ObjectStream に整数オーバフロ ーがあり、リモートの攻撃者が細工した PDF ファイルを用いて任意のコー ドを実行可能です。

  • CVE-2009-3609

    Integer overflow in the ImageStream::ImageStream に整数オーバフロー があり、リモートの攻撃者が細工した PDF ファイルを用いてサービス拒否 攻撃を実行可能です。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 3.02-1.4+lenny2 で修正されています。

テスト版 (testing) ディストリビューション (squeeze) では、この問題は近く 修正予定です。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージ ョン 3.02-2 で修正されています。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02.orig.tar.gz
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02-1.4+lenny2.diff.gz
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02-1.4+lenny2.dsc
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf_3.02-1.4+lenny2_all.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-common_3.02-1.4+lenny2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_alpha.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_amd64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_arm.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_armel.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_hppa.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_i386.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_ia64.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_ia64.deb
PowerPC:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_powerpc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_s390.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-utils_3.02-1.4+lenny2_sparc.deb
http://security.debian.org/pool/updates/main/x/xpdf/xpdf-reader_3.02-1.4+lenny2_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。