Bulletin d'alerte Debian

DSA-2033-1 ejabberd -- Débordement de zone de mémoire du système

Date du rapport :
15 avril 2010
Paquets concernés :
ejabberd
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 568383.
Dans le dictionnaire CVE du Mitre : CVE-2010-0305.
Plus de précisions :

Un problème dans ejabberd_c2s.erl a été découvert dans ejabberd, un serveur XMPP/Jabber distribué écrit en Erlang, qui permet aux utilisateurs distants authentifiés de provoquer un déni de service en envoyant un grand nombre de messages c2s (client2server). Cela déclenche une surcharge de la file, qui à son tour provoque un plantage du démon ejabberd.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 2.0.1-6+lenny2.

Pour la distribution testing (Squeeze), ce problème a été corrigé dans la version 2.1.2-2.

Pour la distribution testing (Sid), ce problème a été corrigé dans la version 2.1.2-2.

Nous vous recommandons de mettre à jour vos paquets ejabberd.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2.diff.gz
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2.dsc
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_armel.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_ia64.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.