Debian セキュリティ勧告

DSA-2033-1 ejabberd -- ヒープオーバフロー

報告日時:
2010-04-15
影響を受けるパッケージ:
ejabberd
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 568383.
Mitre の CVE 辞書: CVE-2010-0305.
詳細:

Erlang で記述された分散 XMPP/Jabber サーバ ejabberd に欠陥が発見されま した。リモートの認証済みのユーザが、多量の c2s (client2server) メッセー ジを送ることで、ejabberd デーモンのキューに過負荷を掛けデーモンをクラッ シュさせることができるため、サービス拒否攻撃を引き起こすことが可能です。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 2.0.1-6+lenny2 で修正されています。

テスト版ディストリビューション (squeeze) では、この問題はバージョン 2.1.2-2 で修正されています。

テスト版ディストリビューション (sid) では、この問題はバージョン 2.1.2-2 で修正されています。

直ぐに ejabberd パッケージをアップグレードすることを勧めます。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2.diff.gz
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2.dsc
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_armel.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_ia64.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/e/ejabberd/ejabberd_2.0.1-6+lenny2_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。