Debian Security Advisory

DSA-2034-1 phpmyadmin -- several vulnerabilities

Date Reported:
17 Apr 2010
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2008-7251, CVE-2008-7252, CVE-2009-4605.
More information:

Several vulnerabilities have been discovered in phpMyAdmin, a tool to administer MySQL over the web. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2008-7251

    phpMyAdmin may create a temporary directory, if the configured directory does not exist yet, with insecure filesystem permissions.

  • CVE-2008-7252

    phpMyAdmin uses predictable filenames for temporary files, which may lead to a local denial of service attack or privilege escalation.

  • CVE-2009-4605

    The setup.php script shipped with phpMyAdmin may unserialize untrusted data, allowing for cross site request forgery.

For the stable distribution (lenny), these problems have been fixed in version phpmyadmin

For the unstable distribution (sid), these problems have been fixed in version 3.2.4-1.

We recommend that you upgrade your phpmyadmin package.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:

MD5 checksums of the listed files are available in the original advisory.