Debian Security Advisory

DSA-2038-1 pidgin -- several vulnerabilities

Date Reported:
18 Apr 2010
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 566775.
In Mitre's CVE dictionary: CVE-2010-0420, CVE-2010-0423.
More information:

Several remote vulnerabilities have been discovered in Pidgin, a multi protocol instant messaging client. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2010-0420

    Crafted nicknames in the XMPP protocol can crash Pidgin remotely.

  • CVE-2010-0423

    Remote contacts may send too many custom smilies, crashing Pidgin.

Since a few months, Microsoft's servers for MSN have changed the protocol, making Pidgin non-functional for use with MSN. It is not feasible to port these changes to the version of Pidgin in Debian Lenny. This update formalises that situation by disabling the protocol in the client. Users of the MSN protocol are advised to use the version of Pidgin in the repositories of

For the stable distribution (lenny), these problems have been fixed in version 2.4.3-4lenny6.

For the unstable distribution (sid), these problems have been fixed in version 2.6.6-1.

We recommend that you upgrade your pidgin package.

Fixed in:

Debian GNU/Linux 5.0 (lenny)

Architecture-independent component:
HP Precision:
Intel IA-32:
Intel IA-64:
Big-endian MIPS:
Little-endian MIPS:
IBM S/390:
Sun Sparc:

MD5 checksums of the listed files are available in the original advisory.