Debian セキュリティ勧告

DSA-2042-1 iscsitarget -- フォーマット文字列バグ

報告日時:
2010-05-05
影響を受けるパッケージ:
iscsitarget
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 574935.
Mitre の CVE 辞書: CVE-2010-0743.
詳細:

Florent Daigniere さんにより、Linux iSCSI ターゲットフレームワーク (Debian では iscsitarget という名称です) に複数のフォーマット文字列バグ が発見されました。この欠陥は、細工した Internet Storage Name Service (iSNS) リクエストにより攻撃可能で、リモートの攻撃者から tgtd デーモンに 対するサービス拒否攻撃をおこなえます。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージョ ン 0.4.16+svn162-3.1+lenny1 で修正されています。

テスト版ディストリビューション (squeeze) では、この問題はバージョン 0.4.17+svn229-1.4 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージ ョン 0.4.17+svn229-1.4 で修正されています。

修正:

Debian GNU/Linux 5.0 (lenny)

ソース:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1.dsc
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162.orig.tar.gz
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1.diff.gz
アーキテクチャ非依存コンポーネント:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget-source_0.4.16+svn162-3.1+lenny1_all.deb
Alpha:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/i/iscsitarget/iscsitarget_0.4.16+svn162-3.1+lenny1_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。