Bulletin d'alerte Debian

DSA-2056-1 zonecheck -- Absence de vérification des entrées

Date du rapport :
6 juin 2010
Paquets concernés :
zonecheck
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 583290.
Dans le dictionnaire CVE du Mitre : CVE-2010-2052, CVE-2010-2155, CVE-2009-4882.
Plus de précisions :

On a découvert que dans ZoneCheck, un outil de vérification de configuration DNS, le CGI ne vérifie pas suffisamment les entrées de l'utilisateur. Un attaquant peut tirer parti de cela et introduire du code de script afin de réaliser des attaques par script intersite.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 2.0.4-13lenny1.

Pour la distribution testing (Squeeze), ce problème a été corrigé dans la version 2.1.1-1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 2.1.1-1.

Nous vous recommandons de mettre à jour vos paquets zonecheck.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/z/zonecheck/zonecheck_2.0.4.orig.tar.gz
http://security.debian.org/pool/updates/main/z/zonecheck/zonecheck_2.0.4-13lenny1.dsc
http://security.debian.org/pool/updates/main/z/zonecheck/zonecheck_2.0.4-13lenny1.diff.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/z/zonecheck/zonecheck-cgi_2.0.4-13lenny1_all.deb
http://security.debian.org/pool/updates/main/z/zonecheck/zonecheck_2.0.4-13lenny1_all.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.