Bulletin d'alerte Debian

DSA-2063-1 pmount -- Fichier temporaire non sécurisé

Date du rapport :
17 juin 2010
Paquets concernés :
pmount
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2010-2192.
Plus de précisions :

Dan Rosenberg a découvert que pmount, un script enveloppe du programme mount standard qui permet à un utilisateur normal de monter des périphériques amovibles sans avoir d'entrée correspondante dans /etc/fstab, crée des fichiers dans /var/lock de façon non sécurisée. Un attaquant local pourrait écraser des fichiers arbitraires en utilisant une attaque par lien symbolique.

Pour la distribution stable (Lenny), ce problème a été corrigé dans la version 0.9.18-2+lenny1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 0.9.23-1, qui migrera bientôt vers la distribution testing (Squeeze).

Nous vous recommandons de mettre à jour votre paquet pmount.

Corrigé dans :

Debian GNU/Linux 5.0 (lenny)

Source :
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18.orig.tar.gz
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1.dsc
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1.diff.gz
Alpha:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_alpha.deb
AMD64:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_amd64.deb
ARM:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_arm.deb
ARM EABI:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_armel.deb
HP Precision:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_hppa.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_ia64.deb
Big-endian MIPS:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_mips.deb
Little-endian MIPS:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/pmount/pmount_0.9.18-2+lenny1_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.